Please Attention! Ubuntu 16.04 Xenial Xerus Does Not Support PHP5 – If you use mysql_connect command at your PHP application, in advance you should delay your desire to upgrade your Ubuntu OS to 16.04 xenial xerus. It happened to me when upgrading my Ubuntu 14.04 LTS to 16.04 LTS, what happened? Ubuntu 16.04 LTS will upgrade php version 5 to newest php version, php7. PHP7 no longer supports mysql extention like mysql_connect().

Ubuntu 16.04 Xenial Xerus Does Not Support Php5

From official site , written that :

This extension was deprecated in PHP 5.5.0 and it was removed in PHP 7.0.0

This causes the application get an error Call to undefined function mysql_connect().., and one solution is switch to PDO or re-install your Ubuntu version to 14.04. This is the best solution I get up today. If you have a better solution, please let me know or send me comment . My advice, it’s time we switched to PDO, if you need to learn PDO, Please read on my tutorial on Connect Bootstrap Login Form and Mysql with PDO.

Thus article about Ubuntu 16.04 Xenial Xerus Does Not Support PHP5, hope useful 🙂

The following two tabs change content below.
This site is a personal Blog of Sigit Prasetya Nugroho, a Desktop developer and freelance web developer working in PHP, MySQL, WordPress.

Leave a Comment

Your email address will not be published.

Time limit is exhausted. Please reload CAPTCHA.